Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 12-28-2021, 06:28 PM   #1
JustinChase
Member
 
Join Date: Jul 2018
Posts: 34
Black tank flush system inlet on top of tank

My 2003 Carriage Carri-Lite came with a black tank flush inlet connection, which I understand will allow me to 'wash the tank from above' by connecting a garden hose to this inlet.


This does seem to work, but my sensors are still all showing it full no matter its actual level. I suspect the flush system 'sprayer' in the tank may not be working. No good way to tell, so I'm considering just replacing it to just be sure it's working. How long can they really last anyway? This one's going on 20 years old.


I can't find any manufacturer data on it, and am having trouble finding a replacement sprayer, so I'm curious if anyone knows where to find a replacement that I can just bolt back into the tank after removing the existing one.


I'm about to redo some of the pex pipe due to a previous owner doing a terrible job when they did some plumbing, and I'd like to do this all as one project, if possible. For example, the inlet on the exterior is actually plumbed into the whole system and the pipe going into the current sprayer comes from someplace in the main system; i.e. it's not a direct pipe from the inlet to the sprayer, for some weird reason


I appreciate any help in finding a good replacement sprayer to hopefully let me eventually get the sensors clean enough to work again.
Attached Images
File Type: jpg flusher.jpg (268.6 KB, 1 views)
__________________

JustinChase is offline   Reply With Quote
Old 12-29-2021, 11:15 AM   #2
Cummins12V98
Senior Member
 
Join Date: Feb 2013
Location: on the road
Posts: 1,154
If you don't have one get a clear 45 sewer fitting to attach to outside 3" discharge. Drain black tank, close black tank then turn on tank flush and run for 5 minutes. Open the valve, does a couple gallons of water flow visibly thru fitting? If so your flush is working.

I drain black then close valve and open flush valve and run for 10 minutes. SET A TIMER ON YOUR PNOHE!!! Now open the valve and when flow slower down close and repeat. Once that is done with tank drained close valve and let flush run for one minute then shut it off. Now your black tank is flushed and cleaned and ready for use.
__________________

__________________
2015 RAM LongHorn Dually Air ride Aisin 4:10's

2016 MS 39TKSB3 "Highly Elited"
Cummins12V98 is offline   Reply With Quote
Old 12-30-2021, 12:40 PM   #3
JustinChase
Member
 
Join Date: Jul 2018
Posts: 34
Thank you for the help.


I can hear the water running when I use the flush, and it does fill the tank, so I know it's flowing, but there's no way to tell if it's flowing out all the holes, or just 1 or 2, and not spraying the walls very well.


I've purchased a product to help clean the crud off the walls and sensors, but to ensure it has the best chance of working, I need to fill the black tank to cover the top sensor, and I'm not sure the best way to do that, without overfilling. I want to assume that once the tank is full, it will begin to back up into the toilet, so I could see this water level thru the toilet, but that's a big assumption, and being wrong seems like it could cause some leaking at a place I cannot see, or be aware of, so I'm hesitant to try filling the black tank, as I'm just not sure when to know when it's full, since the sensors don't work.


Otherwise, I have been doing as you suggest, drain, fill with flusher port, drain, and repeat until it's mostly clear water. I did this last night, and filled and drained 4 times, and the last one didn't show any solids (paper), but the water wasn't exactly clear, it was still light brown. I guess I'll just do it again today a few more times and see how clear that ends up.


Last thing, if my black tank flusher has a check valve built in (I just purchased it), do I still need the vacuum breaker under the sink? Seems plumbing it directly into the top of my tank might be better/easier, and may allow more pressure thru the flusher. If so I'd like to eliminate this extra plumbing and the potential for failure.


I have 50 PSI coming from the city water supply at this location.


Thanks again for your help and input
JustinChase is offline   Reply With Quote
Old 12-30-2021, 05:33 PM   #4
Cummins12V98
Senior Member
 
Join Date: Feb 2013
Location: on the road
Posts: 1,154
I removed my vacuum breakers. They always leak. Simply hold open the toilet and watch for the water to rise to near the top of the tank. Use a flashlight to see into the hole.

Honestly would not worry about the sensors as they never work!
__________________
2015 RAM LongHorn Dually Air ride Aisin 4:10's

2016 MS 39TKSB3 "Highly Elited"
Cummins12V98 is offline   Reply With Quote
Old 12-30-2021, 06:56 PM   #5
Notanlines
Senior Member
 
Join Date: Oct 2017
Location: Germantown, Tennessee
Posts: 709
And screw with NOTHING under the sink.
__________________
Jim and DW 50 years Brenda
2018 40rssa and 2021 Jayco Eagle 40'
2019 F450, ruby red
Harley Road King & sidecar
Notanlines is offline   Reply With Quote
Old 12-30-2021, 08:40 PM   #6
JustinChase
Member
 
Join Date: Jul 2018
Posts: 34
Quote:
Originally Posted by Cummins12V98 View Post
I removed my vacuum breakers. They always leak. Simply hold open the toilet and watch for the water to rise to near the top of the tank. Use a flashlight to see into the hole.

Honestly would not worry about the sensors as they never work!

I fear something may be wrong here. I used the flush inlet to fill the black tank, and it took a LONG time. I'm not even sure I got it full, since the toilet to tank pipe is offset by more than the diameter of the pipe, so I can't actually see into the tank thru the toilet. I filled based on sound, and filled until the sound changed from what sounded like there was splashing to what sounded like simply water running thru the tubing. i assumed this meant the water level had reached the flush tube in the tank.


I kept flushing the toilet, expecting to see the 'burp' bubble when it got full, but I never did get the bubble, and I'm not really sure that's a good sign for full anyway.


The issue is that this took 45 minutes to 'fill' a 38 gallon tank. Seems way too long, but I suppose the few holes in the flusher really restrict the flow, so maybe this is "correct" and that I did get it mostly full and that it did take that long, but it seems wrong.


I added the solution to hopefully loosen the crud, and I hope the water level is actually covering the top sensor. i don't really expect it to work, but it seemed worth a try.


I do wonder if the display will only show the highest level of the sensor it sees as covered, even if lower sensors aren't fouled. i.e. if the lowest 3 sensors are fine, but the top one is bad/covered/fouled, will it show all 4 lights anyway, or would it only show the top light lit, and the lower 3 lights not turn on in this situation? If so, then maybe I only need to clean or replace the top sensor. hard to know.


Quote:
Originally Posted by Notanlines View Post
And screw with NOTHING under the sink.

Why not? The vacuum breaker is here, and I still plan to replace it, so I'll have to 'screw with' it. Honestly, it's pretty simple plumbing work. Cut the line that goes past the tank and run it directly into the flusher, then remove all the pex past that point, including the pex that returns from the breaker to the flusher. One cut, one crimp and one connector to tighten, not too difficult really.


What are you worried may go wrong?


I intend to replace ALL the pex in the rig in the near future, as they have about 1000 elbows installed, and many of the runs are way too long between elbows and rub on the floor and the ceiling of the basement, and the whole system is horribly loud when the pump is actually pumping water thru the system. If I close the valve from the tank, the pump will run, trying to re-pressurize the system, but you cannot hear it at all in the rig. It's only loud when it's actually moving water, which tells me it's the pex making the noise, not the pump (which does have rubber isolation bushings on it)
JustinChase is offline   Reply With Quote
Old 12-31-2021, 06:50 AM   #7
Notanlines
Senior Member
 
Join Date: Oct 2017
Location: Germantown, Tennessee
Posts: 709
It should have read 'kitchen sink.' Remove the vacuum breaker if you think it's what you should do.
__________________
Jim and DW 50 years Brenda
2018 40rssa and 2021 Jayco Eagle 40'
2019 F450, ruby red
Harley Road King & sidecar
Notanlines is offline   Reply With Quote
Old 12-31-2021, 07:11 AM   #8
JustinChase
Member
 
Join Date: Jul 2018
Posts: 34
Quote:
Originally Posted by Notanlines View Post
It should have read 'kitchen sink.' Remove the vacuum breaker if you think it's what you should do.

Thanks, but the question still stands. What do you fear about "screwing with" under the kitchen sink?
JustinChase is offline   Reply With Quote
Old 12-31-2021, 10:04 AM   #9
Cummins12V98
Senior Member
 
Join Date: Feb 2013
Location: on the road
Posts: 1,154
Some worry about cross contamination with removing the Vac breaker. I have shut off valves so the possibility is minuscule to have domestic supply go down and try to draw water backwards. I replaced both with PVC fittings and pipe behind shower valve in bathroom.



__________________
2015 RAM LongHorn Dually Air ride Aisin 4:10's

2016 MS 39TKSB3 "Highly Elited"
Cummins12V98 is offline   Reply With Quote
Old 01-03-2022, 10:12 PM   #10
Larry drv 7*3
Member
 
Join Date: Nov 2020
Posts: 48
Pour dishwasher powder down toilet drain,
lots, like at least a full cup measure
Pour ice down the toilet drain,
At least a bag
Fill tank at minimum 1/2 ful
GO FOR A LONG DRIVE
TURNS, STARTS STOPS CURVES
After at least 1/2 hour drive
Go to sewage dump site
Drain black tank
Refill and dump again
Too bad you cannot go diectly into tank
Perhaps a small hose nozzle
on end of garden hose
Snaked into toilet to flush n spray down tank
Ice and dishwasher powder should clean off sensors
__________________

Larry drv 7*3 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:44 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
×