Free 7 Day Trial RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×
 
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-30-2021, 10:34 AM   #1
Duallyman
Junior Member
 
Join Date: Nov 2015
Location: Az in winter, Summer?
Posts: 1
Water Pump

Recently purchased a 2006 Innsbrook by GS model 24FRBW, Water pump had a blown 10amp fuse. Replaced the fuse and pump continuously runs. Light on the control board always remains on whether pump is unwired or not. Switch on control board ohms out to be working correctly. Any thoughts? I have left messages with factory but no call backs. Iím thinking the control board is bad, but where would I even find a replacement? I have done a internet search with the numbers on board but nothing comes up.

Thank You
David
__________________

Duallyman is offline   Reply With Quote
Old 12-03-2021, 11:26 AM   #2
Cummins12V98
Senior Member
 
Join Date: Feb 2013
Location: on the road
Posts: 1,069
No idea but welcome aboard!!!
__________________
2015 RAM LongHorn Dually Air ride Aisin 4:10's

2016 MS 39TKSB3 "Highly Elited"
Cummins12V98 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:12 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
×