RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
 
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 04-29-2017, 06:27 PM   #1
boonie
Junior Member
 
Join Date: Apr 2017
Posts: 2
New guy with a question

Hi all, I hate being the new guy and asking a question first thing, but I'm frustrated beyond belief with this issue. My girlfriend and I bought a 93 PlayMor fifth wheel for her to use while we are renovating her house. She sleeps in it a few nights every week. When we got it, we were told it needed a new converter, so we replaced and upgraded the converter with a Parallel Dynamics one. We also put a new battery in it. She runs off dc power when she stays there, and uses that sparingly. Eventually, the battery got a bit weak, so I took my generator over, plugged it in, and let it run for a few hours to recharge the battery. Next day, no power. So I brought the battery home, and hooked it to my battery charger here. Battery tests good, has good voltage. Put it back in the camper, and since the jack control is right by the battery compartment, I tried the jack. It went up and down as it should. Went inside, no power. The information panel would show full battery charge until I turned a light on, then it would dim out. Using a 12v test light, I am getting power from the battery, but when I tested at the converter, its not getting power there. Maybe I should mention that everything was working great until the battery started going down, and I recharged it. Ive tried everything I can think of, don't know if it has a transfer switch or a cut off switch, or anything like that. Don't know how it would have gotten moved if it does. If anyone can give me at help or guidance with this issue, I would really appreciate it. This did happen once before, and I replaced some wiring and a couple inline fuses from the battery and it fixed it up. This time, no clue. Thanks in advance for your help
__________________

boonie is offline   Reply With Quote
Old 04-29-2017, 07:29 PM   #2
wingnut60
Site Team
 
Join Date: Sep 2005
Location: Where we park it
Posts: 2,785
So you are using only 12volt and it is not plugged in?
The converter ONLY works off 120volt and puts out 12 volt power to charge the battery--the battery runs everything in the trailer that is 12volt. IF you are not plugged in, the converter can't work.
What is sounds like you are doing is just running the battery down after getting it charged. The gen should have provided 120volt to the converter and then it should have charged the battery up some--takes quite awhile to get any good charge out of the converter.
You probably now need to charge the batter again, but it is going to run down again unless you can get the trailer plugged in.
And, if using a gen to charge the battery, it will go better if you also use an automotive battery charger at the same time--won't hurt anything.
Be sure battery connections are both clean and tight. Also, follow the positive lead to see if you have a relay nearby---if so, check for a tiny black reset button on the side of the relay. Push the button in if there is one. If it is present, and not reset, then it is cutting power off to the 12volt items in the trailer.
Hope some of this helps.
Welcome to our forum.
Joe
__________________

__________________
2016 Tiffin 40 QBH
2015 38RSSA, traded
2005 TK3 #1869, 10 yrs of memories,
2017 F450 KR--one more Ford is it
2009 F450 4x4-died; 2010 F450-retired
wingnut60 is online now   Reply With Quote
Old 04-29-2017, 09:59 PM   #3
boonie
Junior Member
 
Join Date: Apr 2017
Posts: 2
Yea, that's what she is doing. I have the battery out now, and on the charger. I will try it again tomorrow. I thought maybe a dead cell in the battery, but the electric jack will work fine. I did not see any relay on the positive cable, but it goes into a dead space before it comes out again where the jack motor and a fuse block are. It was getting dark, so I'll try to see inside that space tomorrow. I'm kind of leaning toward maybe a break in the wire between the battery and the converter, making an intermittent connection. I also plan to run a wire from the battery to the converter to test that theory, as long as it still is not working in the morning. Thank you for your help, and the welcome.
boonie is offline   Reply With Quote
Old 04-29-2017, 10:45 PM   #4
wingnut60
Site Team
 
Join Date: Sep 2005
Location: Where we park it
Posts: 2,785
Boonie,
If she is going to continue without a 120volt power source, she needs 2 matched batteries, best if they are deep-cycle 6volts in series hookup. Charged batteries will last much longer in this scenario.
The jack is usually wired direct to the battery--it should work no matter what if the battery is good. If the jack is working, there is a wiring problem, possibly a ground wire that is corroded--these type of elec probs are frustrating to find. Remember, the converter does nothing for the system if not connected to 120volt.
I will guess that if she continues this style of living, the single battery setup is not going to be satisfactory. Also, remember there should be a smoke detector, and possibly a CO detector, and maybe a propane gas detector that will constantly draw on the battery whether she is there or not. How about a radio that has instant on? I'm am not familiar with the model/brand, so don't know how they came equipped that far back.
Another solution is a 2nd battery that you bring out daily or as often as needed and exchange them, taking the down one in to charge--but this charge/discharge will quickly shorten the life of any battery.
Hey, wish you some good luck.
__________________
2016 Tiffin 40 QBH
2015 38RSSA, traded
2005 TK3 #1869, 10 yrs of memories,
2017 F450 KR--one more Ford is it
2009 F450 4x4-died; 2010 F450-retired
wingnut60 is online now   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:34 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×