PDA

View Full Version : Low water pressure everywhere


Boltman
08-28-2016, 10:48 PM
I have a 2012 36 RSS ? And you turn on any spigot and the pump just slowly pumps , pump doesn't run hard until I turn on drain spigot.... I don't get it how can I make pump run hard and make pressure. Need some good advice ...

wingnut60
08-30-2016, 10:43 AM
Not entirely sure of problem from your description...what is 'drain spigot' you refer to?

Pump should run to address flow needed--will pump more if more than one tap is open.

What happens if you open sink and lav at same time? How well does the toilet flush?

My first thought is you have some blockage--have you checked the strainer on the pump? But if it was the strainer, it would never pump good.

More details, if possible, will try to give some more ideas.

Joe

rvndave
09-08-2016, 04:32 AM
Might check the water filter.

wingnut60
09-08-2016, 10:19 AM
Water filter doesn't come into play with the pump, at least not on mine...new ones may be different.
Joe

rvndave
09-08-2016, 09:51 PM
Water filter doesn't come into play with the pump, at least not on mine...new ones may be different.
Joe
I was guessing all water went thru the filter. Just bought our rig in signature yesterday and joined this forum to learn. The new to us rv comes home Wednesday and in time I will discover just how everything is plumbed. Thanks for the info!

wingnut60
09-09-2016, 01:20 PM
If you don't have the gravity-fill (fill by sticking hose in opening, not a threaded connection) then everything probably does go thru the filter.
Again, what is the 'drain spigot' you refer to?
Altho my Suites is much older than yours, will try to help all I can...
Joe