Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-27-2020, 01:32 PM   #1
goatherder
Junior Member
 
Join Date: Jul 2020
Posts: 1
Norcold frig issue

Have a 2018 Jayco Eagle w/ a Norcold frig that we are struggling to get to work on LP. Had circuit/control board replaced by factory authorized shop as it was defective. Frequently camp at altitudes above 7500 feet, was told by factory that was the issue. We had a 2016 Jayco bumper pull w/ same model frig that worked fine. Have camped at altitude for decades with various models/manufacturers and never experienced this. Frig cools fine if lit manually but won't consistently lite automatically. Any similar issues or thoughts
__________________

goatherder is offline   Reply With Quote
Old 07-30-2020, 12:07 PM   #2
wingnut60
Site Team
 
Join Date: Sep 2005
Location: Where we park it
Posts: 2,752
Might have oil residue in lines causing restriction in line to gas control, tho if it lights manually, sounds more like an igniter problem. Maybe the spark isn't strong enough--is the gap correct?
__________________
2016 Tiffin 40 QBH
2015 38RSSA, traded
2005 TK3 #1869, 10 yrs of memories,
2017 F450 KR--one more Ford is it
2009 F450 4x4-died; 2010 F450-retired
wingnut60 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:55 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×