PDA

View Full Version : Water Heater Issues


Hoonah Dave
09-26-2020, 09:48 PM
I have a Suburan SW12DE water heater in our 2013, 41RSSB. The Propane function just stopped working. Electric works fine.

When I select Propane, it fires up for a fews second. Good Flame, and then goes out and the DSI light illuminates. It makes 3 attempts and then stops trying. Propane levels are good. We know the Igniter is working as the flames fires, but it only stays lit for about 3 seconds each time.

I am thinking it is the control board? Any thoughts.

Also, any input on the location of the control board would be appreciated. I contacted DRV and asked about the location of the control board this is what they wrote back:

"It will be on the side of the water heater tank. On the forward facing side towards the rear. Accessible from the storage area."

I have looked and looked to no avail.

Any input on the cause of my issue, a fix for my issue, or the location of the control board would be greatly appreciated.

Dr. D
10-05-2020, 05:06 PM
Bad thermocouple. It thinks it didn't light, maybe.

wingnut60
10-07-2020, 11:28 PM
Thermocouple would be easiest and cheapest to replace first...

GeoTech
10-11-2020, 07:14 AM
There is no thermocouple in direct spark water heaters. They use an electrode & flame rectification to sense the flame. A lot of issues with this type of system results from impurities in the air (such as dust, moisture, etc.) being burned Onto the flame "rod" a simple cleaning with an alcohol type eyeglass lens cloth should work ok. DO NOT use sandpaper or a file! Most flame rods/sensors have very tiny groves along the length giving more surface area to detect the flame. sanding can leave residue in these groves that will burn onto the rod.