PDA

View Full Version : Black water tank won't drain? Valve stuck?


Jerapais69
05-04-2019, 11:26 PM
All,
I have a 19 Fuzion 427 with 2 black 2 gray tanks. The main black tank valve does not move in and out like the other 3, seems to "bounce back" when pushed in and doesn't go all the way. Likewise, it doesn't go out all the way and seems to "bounce back" out when pushed in, tho not all the way.

When i pull the T valve on the black tank, nothing comes out. I use the King Flush system by Valterra AFTER using the rv flush system and use a toilet stick as well. When i flush this black tank with the king flush system, the water does not freely spray as it does with the other 3 tanks. Just seems to "fill up" and you cannot see the water jetting into the waste pipe.

The ultimate irony is that this tank NEVER seems to fill! Add to that the fact that the black and gray tank valves are switched.
Lost.....

OCB
05-05-2019, 09:25 AM
ith the RV being a 2019, I would say the Dealer/Mfg has a problem.

Go get what your money was to Buy, Some Satisfaction.
Clay

Jerapais69
05-05-2019, 09:30 AM
Yes, have scheduled to take in but they can’t fit me in till Sept, so they say. (Place of purchase 5 hours away and closest camping world is 1.5 hours.) and I live in it!

OCB
05-05-2019, 10:05 AM
Does Keystone approve of others to do warranty work?
By others I saying other dealers or independent mobile repair crews?
You mentioned Camping World, did you purchase from Camping World?
Which part of the country are you located?
Clay

Jerapais69
05-05-2019, 10:44 AM
Yes they do but only Camping World around here and no I didn’t buy from them. Pittsburgh Pa thx

Notanlines
05-05-2019, 05:49 PM
Paul, is this the black tank for your half bath in the rear? If so, where is the location of the T-handle to operate the valve?

Jerapais69
05-05-2019, 05:56 PM
Hey NTL, no front one. Thx for jumping in.

Notanlines
05-05-2019, 07:07 PM
Not a chance that I would wait for that time period. Can we assume (there's that word) that you are speaking of one of the two handles in the service center? If so, locate the subject black tank under the RV. Remember, the most likely exit on the tank will be at the driver's side or the rear of the tank. You will need to make a small cut in the coroplast initially to first locate the offending valve, and then a large opening so you can work on the valve and find out what the problem is. Your first cut should be about 6-8" long by 6-8" wide, just an 'L' cut so you can pull it aside and see with a flashlight the exact location of the valve. Have a second party try to operate the valve while you watch the action at the valve. If it something that you can repair, make your cuts longer, now in a 'U' shape, leaving the front of the flap towards the front of the trailer. The flap is easily repaired with a number of goodies, most common being black Gorilla tape. You may very well have some insulation on top of the coroplast.
At this point, have your wife get her hands up in there and move the insulation out of the way. She's done very little at this point, so let her suffer!
Yes, I'm just having a little fun here. Better that no one fools with the insulation without some disposable latex gloves!
You will possibly find a binding cable or something simple as this. You also may find this cable being 9' long and just too stiff to work properly. Keep us up on your progress.

Jerapais69
05-05-2019, 07:31 PM
You are funny NTL! You’re right. I’m not gonna wait. Sounds like you’ve done this before. I heard it was no big deal to change out.
I went into the basement, opened up the walls and found the cables. The black cable IS indeed long and both travel below the “floor” to the underbelly of the unit. I’ll have to cut it open as you said. I’m new at this but I’d bet my farm the valve is faulty. It doesn’t work at all like the other 3. Weirdly, not only does the tank not drain, it doesn’t fill either. ...????

OneReallyOldGuy
05-13-2019, 05:56 PM
Just lurking here on this thread and I dread the day I have black tank problems. You said the tank never fills. Its got to be going somewhere. Are you positive there are two black tanks? Is there ever a sewage smell around your unit? Ever see water leaking out from under the camper? Id be really careful opening up the underbelly. You might get a face full of something 100 times more gross than insulation.

jr2194
05-13-2019, 06:09 PM
I have a 2017 Fuzion 371.... I too have had problems with my tank valves. Spraying silicone lube down the cable and a little dawn with water in the tank helped all my valves to operate properly... however one of my black valves does leak by a bit so I installed a gate valve just before the hose until I decide to tackle the change out. I’m confused with you saying nothing comes out and it doesn’t fill up... on mine there is a second black tank valve behind the driver side tire. Be careful using the flush system without the valves open... there is a pressure check valve under the sink that may make a mess if too much pressure builds up. ... also if mine was new and having this issue and the dealer said September... I’d be calling Keystone! Good luck!