PDA

View Full Version : No 12v lights in slide outs


don a
05-08-2016, 06:55 PM
2008 mobile suite 36sbtk need help trying to find a short blowing 20amp fuse for 12v lights on both rear slides and dometic fridge also not working that is on slide also. took all wall 12v switches out to look for loose connections. look under slides for wire loom with 12v wires did not find any wires with chafing. any info would be great. thanks don

wingnut60
05-09-2016, 08:28 AM
On my '05, there is a junction box on the frame for each large slide. Have you checked in there for loose connections/water, etc?
Sounds odd that both sides would be out at same time...

don a
05-09-2016, 09:29 AM
yes I did check junction boxes those are 110v ac. my problem is 12v dc their is wire loom with 12v wires at back of each slide that's for 12v lights and anything 12v no power to lights on both slides the slide in bedroom is ok

wingnut60
05-09-2016, 11:53 AM
Is there only the one fuse that keeps blowing?

don a
05-09-2016, 12:22 PM
Yes only one 12v #7 on panel marked slide light 20amp

wingnut60
05-09-2016, 02:39 PM
#7 in my trailer is also marked 'slide light' and is a 20amp. Since your fridge is not working anyway, I would go into the back of the fridge and disconnect both the 120 plug and take apart the 12volt fused connections. Then I would put another fuse in and see if it blows again--if not, the problem is in the fridge area. Also, look at the fridge fuses themselves to see if either of them is blown.
If both the 12volt fridge fuses are good, prob can forget them. If the fuse blows again with the fridge out of the circuit, then the prob is elsewhere, and I don't know where to start chasing it as I have no idea how many actual items are on the same circuit.
Joe