PDA

View Full Version : non of exhaust fans work


webatts
12-07-2015, 08:56 PM
I don't see any recent posts but thought I would give this a try.

Last weekend I moved my 5r from a long term spot that I had it to it's spot on the farm. After setting up I decided to turn fantastic fan on, would not work. The v ked fuse no issue, went out side and checked all fuses, all good. Decided to check fans over shower and toilet area, they didn't work. Unchecked every fuse. No issues. I have all book from carriage from original purchase but in no wiring diagram. I have searched web and cannot find one. Anyone know where Imght find one?

MooseSuite
12-08-2015, 04:11 AM
They have great service and tech support. Contact Fantastic Vent http://www.fantasticvent.com/fan-tastic-vent-s-contact-us.html

I think you are looking for a wiring diagram and the fuses are ok. Yu might try spraying silicone on the safety plunger, top side. These will stick closed, thus no fan operation.

webatts
12-08-2015, 06:28 AM
Thanks, I have done those checks on FF. My issue is that all the fans do not work as well. On previous RVs, the fans were on the same 12vdc circuit, I have checked fuses in the 12 volt panel outside and found no issues. I wonder if there is a another feed for the fans

MooseSuite
12-08-2015, 09:16 AM
Fantastic Vent Is a good product. Not knowing what you are comparing, year model etc I can't think of anything further. You can check the volts going to the fan motor , but both fans not operating to your expectation. If in warranty Fantastic Fan will replace, they will also trouble shoot your issue over the phone. I'm not sure if you have done this.
I assume you have checked your battery load output.

webatts
12-08-2015, 09:22 AM
There is a 12 VDC circuit that provides power to the three fans . No power to any of them. They are evidently not being fed from 12 volt fuse panel as all fuses are good. Was just looking for a wiring diagram for a 2002 Carriage to see if it would indicate what was on that circuit so I could trace issue down. Thanks for your comments.

wingnut60
12-08-2015, 11:55 AM
Have yet to see a wiring diagram/schematic on any trailer/fiver. Sounds strange that both would not have power. Is anything else on 12volt power not working?
Joe

Kerry
12-18-2015, 12:44 AM
Has to be something simple, your missing something. Carriage doesn'thave a combination ac/dc convertor. It has a breaker box for the ac , and a stand alone 12 volt supply converter in the underneath storage area. Physically check all the fuses and that 12v is on everything leaving the converter. (mine was in the storage area where the generator goes.

webatts
12-18-2015, 07:07 AM
AC/DC converter is working, wire from converter is on the same buss bar, wire from Buss goes to 12DC, all fuses are good, each wiring coming out of 12VDC is hot ((12vdc).
Update, wife called me at work, said she went into 5er and all three fans were running. I can't be certain, but I suspect that when I went to truck stop for a wash job, something got wet (I could get 8.5 VDC) After sitting in sun it dried out. Dropping off at camping world to have roof inspected and recoated on Monday when we return from Tybee Island.