Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-13-2016, 12:09 PM   #1
GBill
Junior Member
 
Join Date: Aug 2015
Location: Tennessee
Posts: 10
Converter malfunction

Having what to me is a strange issue with a progressive dynamics DP 9180 converter. The voltage out put from the converter with the out put leads removed is 13.8V. Here is where it gets strange. When the out put leads are connected to the converter and yet disconnected at the batteries the voltage drops to 2.2V. I did install a new charge wizard first but no luck. That when I checked further and discovered this issue. Cleaned all the connections but no go. Anybody ever run across anything similar to this? Hate to replace it only to find it is something else. Oh and the so called salesman 12v switch is working OK. Thanks
__________________

GBill is offline   Reply With Quote
Old 03-13-2016, 04:44 PM   #2
wingnut60
Site Team
 
Join Date: Sep 2005
Location: Wherever the Suites is
Posts: 1,840
Not sure about your problem, but if you might be interested--
I have a newly reman PD9180 w/CW. Mine went out and could not wait for shipping to factory, so bought a new one. Then went ahead and sent it in for reman. I believe the cost was $116. I'd take $100 + shipping if you want to try it.
One other item to check--you are sure both batteries are good?
Joe
__________________

__________________
2015 38RSSA #7382
2005 TK3 #1869, 10 yrs of memories
2017 F450 KR--one more Ford is it
2009 F450 4x4-died; 2010 F450-retired
wingnut60 is online now   Reply With Quote
Old 03-14-2016, 12:09 PM   #3
GBill
Junior Member
 
Join Date: Aug 2015
Location: Tennessee
Posts: 10
Joe thanks for the reply. Near as I can tell the batteries are OK. One is showing 6.4V and the other is 6.5V. I don't own a hygrometer if I spelled that right. The voltage drop happens even when the leads from the converter are disconnected from the batteries. Really odd symptom. Just came back from Fla and lived in it a month with no trouble. Thanks for the offer on the recon but I think I'll replace this one with a 9280. I have the converter apart on my bench and it does show one pretty good hot spot on the board which may be normal but it did do a hard charge in Alabama on the way home and thinking back I didn't hear the fan at all and for that matter haven't heard it in a long time. Oh I did call the manufacturer. Talked to a women who then talked to someone and back and forth several times. I was told that they think "something is wrong with the converter". Really! Also because of it's age they wouldn't repair it but would sell me a reman at $200+. If I can repair it I'll keep for a spare like you and carry it around and probably never use it. Thanks again. PS Do you want a spare charge wizard. Brand new used 30 seconds. If so PM or Email me an address.
GBill is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:58 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.