Notices

Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-26-2019, 01:10 AM   #1
rkj2792
Junior Member
 
Join Date: Jun 2019
Posts: 1
Electrical Issue

I have a 2002 29' Dutchan Aerolite with a Centurion 3000 model cs4500. I'm completely clueless to all things electric but my husband is a little better and were having an issue with the control panel. There's a kind of hiss like sound coming from it, then it sorta makes the lights dim out and kinda flicker. My husband thought it might have a lose connection but not entirely sure. Any suggestions or opinions
__________________

rkj2792 is offline   Reply With Quote
Old 06-28-2019, 06:50 PM   #2
wingnut60
Site Team
 
Join Date: Sep 2005
Location: Wherever the Suites is
Posts: 2,501
Might find some help here:

http://www.bestconverter.com/Centuri...ent-_c_63.html
__________________

__________________
2015 38RSSA #7382
2005 TK3 #1869, 10 yrs of memories
2017 F450 KR--one more Ford is it
2009 F450 4x4-died; 2010 F450-retired
wingnut60 is offline   Reply With Quote
Old 07-03-2019, 05:36 PM   #3
Dr. D
Junior Member
 
Join Date: Oct 2005
Location: Riva, MD
Posts: 8
This "hiss" sounds an alarm bell in me. Have a qualified electrician inspect it.
Dr. D is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:29 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.