Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-05-2019, 05:51 PM   #1
Scott N.
Junior Member
 
Join Date: Feb 2017
Location: Mesa AZ
Posts: 3
Water leak ONLY when using the pumpů..

2006 Keystone Montana Mountaineer: I have a sporadic leak (big leak) when I turn on the water pump. Water is escaping out of the back of the unit spilling on the ground. I was on the road at the time so I could not do anything until the next day. I thought I had a broken or disconnected pipe. The pump itself and all the plumbing under the fridge are all dry. I peeled of the underbelly (pain in the butt) at the back of the unit and could not see any broken or loose connections. I went inside and turned on the pump and everything was fine, no leak and the pump only ran when a faucet was on, like is supposed to. I put everything back together. A few days later, it happened again. I did not use the pump again during the trip. When using city water everything is fine, no leaks. I got home and now the pump works fine again, no leaks. Is there a pressure relief valve on this unit (besides the water heater) that may be going off intermittently? That is the only thing I can think of.
Scott N. is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:15 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.