Reply
 
Thread Tools Search this Thread Display Modes
 
Old 12-26-2017, 06:19 AM   #1
dmascheck
Senior Member
 
Join Date: Sep 2017
Posts: 117
DC electrical switch?

I have a 2006 King of the Road Royal Villa. There is, what I thought a main shut off switch to the trailer I thought for DC voltage. It's a large black knob on a red or orange backing.

Please see picture. I did put a new intelligent converter to replace the old one. Replaced wire to wire which was simple enough! Seems to be working fine charging the batteries!

I accidently left the overhead LED lights on, but always shut off the large switch in the control panel with all the small DC fuses. Next day I opened the trailer up to work on it and forgot to turn the main switch on and noticed the lights were on. I thought I must have forgotten to turn the switch off. I opened the panel and to my surprise it was off, but the lights inside were on?? Sure is odd! I need to do some checking with my Volt meter.
Attached Images
File Type: jpg IMG_5864.jpg (133.5 KB, 8 views)
__________________

dmascheck is offline   Reply With Quote
Old 12-26-2017, 08:29 AM   #2
wingnut60
Site Team
 
Join Date: Sep 2005
Location: Wherever the Suites is
Posts: 1,909
Well, lights are getting power from somewhere--faulty cutoff switch?
__________________

__________________
2015 38RSSA #7382
2005 TK3 #1869, 10 yrs of memories
2017 F450 KR--one more Ford is it
2009 F450 4x4-died; 2010 F450-retired
wingnut60 is offline   Reply With Quote
Old 12-26-2017, 09:21 AM   #3
dmascheck
Senior Member
 
Join Date: Sep 2017
Posts: 117
Makes me wonder? Time to break out the volt meter. I’d swear it worked before. I did add the new converter, but it was a wire for wire swap except the direct case ground to the body/frame of the trailer.
dmascheck is offline   Reply With Quote
Old 12-26-2017, 04:20 PM   #4
porkchop
Senior Member
 
Join Date: Sep 2010
Location: Nebraska
Posts: 177
Looks to me like only 1 circuit is connected to switch thru a relay?

Bill
porkchop is offline   Reply With Quote
Old 12-26-2017, 05:53 PM   #5
dmascheck
Senior Member
 
Join Date: Sep 2017
Posts: 117
I don't think so. If your looking at the block it's tied to, there is a jumper. Look close. I need to get the volt meter out and do some checking.

Thanks!
dmascheck is offline   Reply With Quote
Old 12-27-2017, 12:31 AM   #6
Rockyhud
Member
 
Join Date: Nov 2017
Posts: 68
Any chance the switch is defective and that it still has closed contacts when it's in the OFF position? Also, is it possible a single or more than one strand of wire crossed over from one terminal to the other when the wires were attached to the switch and weren't seen?

Every time I start troubleshooting I ALWAYS remind myself to use the KISS principle and start checking the simple and sometimes overlooked possibilities first. As example, it's kind of like troubleshooting a computer that has a network connectivity problem, One could start thinking the problem could be a bad network card (NIC) or maybe the NIC drivers need updated or something worse when the actual problem is the network cable isn't plugged into the NIC port. Not saying simple causes like these are necessarily the case with your switch, but could be. Hope you find it easily.
__________________
Steve and LaDonna
RV: 2011 Mobile Suites 38TKSB3 #5509, with several options to make living in it nice.
Truck: Beefed up 97 Ram 2500 4x4 with 12-valve Cummins, 5-speed, long bed. Tows the DRV very nicely.
Rockyhud is offline   Reply With Quote
Old 12-27-2017, 05:51 AM   #7
dmascheck
Senior Member
 
Join Date: Sep 2017
Posts: 117
I fully agree, that many times the simplest thing is the answer. I'll unhook wires and do a continuity test on the switch first. Then if it's OK, we run wires!
__________________

dmascheck is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:20 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.