Notices

Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-25-2019, 11:23 PM   #11
Jerapais69
Member
 
Join Date: Feb 2019
Posts: 34
I see it now. No need for a multimeter here. Thx. I don’t have that. I’m totally perplexed. Heating element is fine as I replaced that too.
__________________

Jerapais69 is offline   Reply With Quote
Old 02-26-2019, 08:04 AM   #12
onetonford
Junior Member
 
Join Date: Jan 2012
Location: Northern California
Posts: 11
The next weak link in the circuit would be the little rocker switch on the outside of the heater. I know that my unit has the power cord plugged in under the sink in the cabinet I would unplug it and plug a light into it to see if it was working other wise there is no other spot in that circuit that could be bad.
Attached Images
File Type: png Screenshot_3.png (59.7 KB, 1 views)
__________________

__________________
2001 Ford F350 7.3 CC LB DRW
2011 Wildcat 25 RL
Maintenance Mechanic 40+yrs
onetonford is offline   Reply With Quote
Old 02-26-2019, 08:31 AM   #13
Jerapais69
Member
 
Join Date: Feb 2019
Posts: 34
I’ll try that. Thanks.
Jerapais69 is offline   Reply With Quote
Old 02-26-2019, 03:19 PM   #14
MTK46
Senior Member
 
Join Date: Dec 2018
Location: Desert Hot Springs Ca.
Posts: 108
Quote:
Originally Posted by onetonford View Post
Here is a picture and the unit for the 110V is blown they sometimes do this when the element shorts out. These are found under the cover with the rubber plugs in it.
I had to replace my 120V heating element and it doesn't look like what you posted.
water heater element.jpg
Is round.
__________________
Mike & Trish Romans 10:9
2011 Mobile Suites 36RSSB3 #5556
2014 F-350 CC 6.7 diesel dully
MTK46 is online now   Reply With Quote
Old 02-26-2019, 03:44 PM   #15
Jerapais69
Member
 
Join Date: Feb 2019
Posts: 34
I didn’t post a heating element unless you mean someone else.
Jerapais69 is offline   Reply With Quote
Old 02-26-2019, 04:21 PM   #16
onetonford
Junior Member
 
Join Date: Jan 2012
Location: Northern California
Posts: 11
Quote:
Originally Posted by MTK46 View Post
I had to replace my 120V heating element and it doesn't look like what you posted.
Attachment 947
Is round.
Those are the reset/thermostat.
__________________
2001 Ford F350 7.3 CC LB DRW
2011 Wildcat 25 RL
Maintenance Mechanic 40+yrs
onetonford is offline   Reply With Quote
Old 02-26-2019, 04:50 PM   #17
MTK46
Senior Member
 
Join Date: Dec 2018
Location: Desert Hot Springs Ca.
Posts: 108
Quote:
Originally Posted by Jerapais69 View Post
I didn’t post a heating element unless you mean someone else.
Referring to onetonford post
__________________

__________________
Mike & Trish Romans 10:9
2011 Mobile Suites 36RSSB3 #5556
2014 F-350 CC 6.7 diesel dully
MTK46 is online now   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:51 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.