Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-24-2019, 04:19 PM   #1
mikesas@sstelco.com
Junior Member
 
Join Date: Jul 2019
Posts: 3
Help

2018 Keystone Cougar 5th wheel, camped for a week everything works fine, time to go home, bedroom slide retracts, kitchen and dining slides won't move. Cranked them in with electric drill drove home. After arriving home all slides worked.
Please let me know your thoughts
__________________

mikesas@sstelco.com is offline   Reply With Quote
Old 07-25-2019, 11:58 AM   #2
Notanlines
Senior Member
 
Join Date: Oct 2017
Location: Germantown, Tennessee
Posts: 384
Mike, very first thing is to investigate the true condition of your batteries. They need to be at 100%.
__________________

__________________
Jim and DW 47 years Brenda
2017 38rssa
2019 F450, ruby red
Harley Road King & sidecar
Notanlines is offline   Reply With Quote
Old 07-25-2019, 01:10 PM   #3
mikesas@sstelco.com
Junior Member
 
Join Date: Jul 2019
Posts: 3
Quote:
Originally Posted by Notanlines View Post
Mike, very first thing is to investigate the true condition of your batteries. They need to be at 100%.



I was hooked into 110 and only the bedroom slide worked, when I got home I tried them with both the battery and 110 and they all worked on both.
mikesas@sstelco.com is offline   Reply With Quote
Old 07-27-2019, 01:48 AM   #4
wingnut60
Site Team
 
Join Date: Sep 2005
Location: Wherever the Suites is
Posts: 2,630
Again, please take the batteries out and have them load tested--only way you will know for sure.
Should have worked on batteries only--the power for the slides is 12 volt. Being plugged in only sends power to the converter that charges the batteries. Clean all terminals on the batteries also.
Let us know what you find.
__________________
2015 38RSSA #7382
2005 TK3 #1869, 10 yrs of memories
2017 F450 KR--one more Ford is it
2009 F450 4x4-died; 2010 F450-retired
wingnut60 is offline   Reply With Quote
Old 08-05-2019, 05:03 PM   #5
mikesas@sstelco.com
Junior Member
 
Join Date: Jul 2019
Posts: 3
Found a loose ground cable on the battery - THANKS VERY MUCH
mikesas@sstelco.com is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:23 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×